c2f93120c221

Import the with statement all the time.  There are no ill effects on 2.6+.
[view raw] [browse files]
author Steve Losh <steve@stevelosh.com>
date Thu, 23 Jul 2009 01:49:21 -0400
parents a62c8ab6c87f
children 35e941dc16cb
branches/tags (none)
files README prompt.py

Changes

diff -r a62c8ab6c87f -r c2f93120c221 README
--- a/README	Wed Jul 22 21:23:31 2009 -0500
+++ b/README	Thu Jul 23 01:49:21 2009 -0400
@@ -8,13 +8,7 @@
 Requirements
 ------------
 
-hg-prompt requires Python 2.6 and makes use of some of the nifty new features.  
-
-If you'd like to use it with Python 2.5, you'll need to add the following line at the top of the `prompt.py` file (right after the `#!/usr/bin/env python` line):
-
-    from __future__ import with_statement
-
-That's two underscores on each side of the word "future".
+hg-prompt requires Python 2.5 and (obviously) Mercurial.
 
 Installing
 ----------
diff -r a62c8ab6c87f -r c2f93120c221 prompt.py
--- a/prompt.py	Wed Jul 22 21:23:31 2009 -0500
+++ b/prompt.py	Thu Jul 23 01:49:21 2009 -0400
@@ -1,6 +1,5 @@
 #!/usr/bin/env python
 
-# Uncomment next line if using python 2.5x
 from __future__ import with_statement
 
 '''get repository information for use in a shell prompt